
 

 

 

 

 

 

 

 

 

Official JSN Epic v3 

Quick Start Guide 

This documentation is release under Creative Commons Attribution-Non-Commercial-Share Alike 3 Unported 

Licence. You are free to print this document for convenient usage. 

Copyright © 2006 - 2010 http://www.joomlashine.com 



Joomla! template JSN Epic v3 Quick Start Guide © http://www.joomlashine.com 

 2

Table of Contents 

Official JSN Epic v3 Quick Start Guide..............................................................................................................1 
Table of Contents .................................................................................................................................................................2 

Introduction ...........................................................................................................................................................................4 

First steps ..............................................................................................................................................................................5 

Template installation...........................................................................................................................................5 

Template parameters .........................................................................................................................................6 
Sample data ...........................................................................................................................................................................7 

Sample data installation .....................................................................................................................................7 

Original data restoration.....................................................................................................................................8 
Website title configuration.................................................................................................................................................9 

Favicon configuration .......................................................................................................................................................10 

Header area configuration ...............................................................................................................................................12 

Logo ....................................................................................................................................................................12 

Top Menu ...........................................................................................................................................................13 

Main Menu..........................................................................................................................................................15 

Site Tools............................................................................................................................................................17 
Primary Promotion area configuration .........................................................................................................................18 

Header image slideshow..................................................................................................................................18 

Featured user modules ....................................................................................................................................21 
Left column configuration ...............................................................................................................................................22 

Tree Menu ..........................................................................................................................................................22 

Login Form .........................................................................................................................................................24 

Syndicate ............................................................................................................................................................26 

Stick Left Module...............................................................................................................................................27 
Right column configuration.............................................................................................................................................28 

Newsflash ...........................................................................................................................................................28 

Polls.....................................................................................................................................................................30 

Who’s Online......................................................................................................................................................32 

Stick Right Module ............................................................................................................................................33 
Main content area...............................................................................................................................................................34 

Welcome module ..............................................................................................................................................34 

About Us module...............................................................................................................................................36 

Latest News .......................................................................................................................................................38 

Popular................................................................................................................................................................39 

Bottom Banner...................................................................................................................................................40 
Footer area configuration ................................................................................................................................................41 

3 bottom promotion modules...........................................................................................................................41 



Joomla! template JSN Epic v3 Quick Start Guide © http://www.joomlashine.com 

 3

Copyright text.....................................................................................................................................................43 

Div Menu ............................................................................................................................................................44 

What’s next? ......................................................................................................................................................46 

Read the latest updated tutorials....................................................................................................................46 

Give a feedback ................................................................................................................................................46 



Joomla! template JSN Epic v3 Quick Start Guide © http://www.joomlashine.com 

 4

Introduction 

 

Thank you for your interest in JSN Epic template. We really appreciate your choice and truly wish our product 

will bring more value to your website and business. 

To have the best template understanding, we recommend you to read documentation in following order: 

1. JSN Epic Quick Start Guide – This document will tell you how to get the template look like the demo 

website as well as the main concept of how to work with the template. 

2. JSN Epic Configuration Manual - This document will give detailed information about each template 

feature and how to apply it to your real website. 

3. JSN Epic Customization Manual - This document will teach you how to customize the template to make 

it suite you need. 

You can print all documents for convenient reading. 

Notes: 

- This document assumes that you already have installed Joomla! CMS with sample data and JSN Epic 

template. 

- Features marked with  are available only in JSN Epic PRO Edition and NOT available in Free 

Edition. 

Let’s roll! 
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First steps 

Template installation 

In the download package you can find template installation file called jsn_epic_XXX_3.Y.Y.zip, where XXX is 

the template edition and YY is the template version you have. This is standard Joomla! 1.5.x template installation 

file which can be installed in Joomla! administration normally as following: 

1. In Joomla! administration go to menu Extensions -> Install/Uninstall 

2. Once you are on Extension Manager click Browse button and select template installation file 

jsn_epic_XXX_3.Y.Y.zip. After that click on button Upload File & Install. 

3. Installation file will be uploaded to your server and installed in Joomla! CMS. 
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Template parameters 

 

JSN Epic provides 40 template parameters for incredible configuration. To setup template parameters, please 

make following steps: 

1. First, go to template manager by menu Extensions -> Template Manager. 

2. Next, click on template name JSN_Epic_XXX, where XXX is template edition you have. 

3. Next, in the Template Edit page you will see the list of template parameters in section Parameters. For 

your convenience, all parameters are located in dedicated collapsible sections. You need to open 

appropriate section and configure parameters you want. 

4. Finally, click button Save or Apply to save all changes you made. 
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Sample data 

 

JSN Epic has very useful feature of installing sample data to make your testing website looks the same as on 

template demo website. Unlike other template providers who give you heavy package with all files and database of 

the demo website, we just give you single link to install sample data right on your current website. More over, we 

provide you an option to backup all current data, so you can restore them later, when finish with template testing. 

Sample data installation 

To perform sample data installation please make following steps: 

1. First, go to template settings page open section SAMPLE DATA and click link Install sample data 

2. Next, on page JSN Epic Sample Data Installation it’s important to read all information. After that, input 

your Super Administrator account, check the box to agree with terms and click button Install Sample Data 

3. Finally, if everything is ok, you should be redirected to page JSN Epic Sample Data Successfully 

Installed. From here you can: 

 Download backup file of the original content that has been replaced by sample content. Read next 

section to learn more about how to use backup file to restore original data 

 Return to template settings page for further configuration. 

 Go to website front-page to ensure it looks like template demo website. 

http://localhost/joomlashine/dev/j15/dev1/index.php
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Original data restoration 

The backup file of the original content that has been replaced by sample content can be downloaded after sample 

data installation or from the folder /tmp inside Joomla root folder on your server. Technically, this is the zip file 

which contains a plain text file with SQL instruction that need to be executed on your Joomla database. 

Bellow is the instruction of how to do that by using software phpMyAdmin 3.2.1. 

1. First, login to phpMyAdmin and select your Joomla! database on the left column 

2. Next, select tab Import on horizontal menu bar 

3. Next, click button Browse.., then select backup zip file and click button Go at bottom right corner of the 

page. 

After script execution you can get back to your website to check how original data were restored. 
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Website title configuration 

 

To change website title please make following steps: 

1. In Joomla administration panel, go to Menus -> Main Menu 

2. Next, in Menu Item Manager page, select item Home 

3. Next, Menu Item page, open section Parameters (System) and change parameter Page Title as you 

desire. 
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Favicon configuration 

Favicon is small icon standing on the left of address bar of your browser. By default Joomla! has the icon as shown 

in screenshot bellow. 

 

Default Joomla! favicon 

On your website you might want to use your own icon, like the one we are using on our site joomlashine.com. 

 

JoomlaShine favicon 

Here is instruction how to do that. The process consists of 2 main stages: 

Stage 1: Create your own favicon file 

Technically favicon is regular 16px * 16px icon file with exact name favicon.ico. In most cases favicon is the 

sized-down version of the company logo saved in icon format. In some cases the logo is too specific and favicon 

need to be built from the scratch. You can use professional icon editor software like Axialis IconWorkshop and 

Iconcool Editor or to use online favicon generators. The first method gives you better quality, but takes more 

efforts. The second method is easier, but quality is not the best. 

Stage 2: Upload favicon file to your server 

After you got favicon file, it’s time to upload it to your server. You need to upload the icon file to folder 

joomla_root_folder/templates/jsn_epic_XXX/, where XXX the template edition you have and overwriting the 

http://www.axialis.com/
http://www.iconcool.com/icon-editor.htm
http://www.google.com/search?q=favicon+generator&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-GB:official&client=firefox-a
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default file. Feel free to make experiments. Anytime you can get back default favicon file from Joomla! installation 

package. 

If you have permission problems while using FTP, then we strongly recommended you to use great Joomla 

extension called JoomlaXplorer. You can download it for free from JED at: 

http://extensions.joomla.org/extensions/core-enhancements/file-management/102 

If you don’t see your new icon, that doesn't necessarily mean you did anything wrong. Browsers are designed to 

minimize data traffic, so they don't refresh the favicon every time they show a page. Even refreshing the page (F5) 

won’t help. So you need to refresh more thoroughly: 

 Mozilla / Firefox / Safari: hold down Shift while clicking Reload, or press Ctrl-Shift-R (Cmd-Shift-R on 

Apple Mac) 

 Internet Explorer: hold Ctrl while clicking Refresh, or press Ctrl-F5 

 Konqueror: simply click the Reload button, or press F5 

 Opera: users may need to completely clear their cache in Tools -> Preferences 

 Chrome: Shift-F5 

If this doesn't work you will need to delete the temporary internet files and the history and then open your page 

again. 

http://extensions.joomla.org/extensions/core-enhancements/file-management/102
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Header area configuration 

Logo 

 

The logo JSN Epic is default sample logo and you should replace it with your own. Technically logo is an image 

file called logo.png and located in folder joomla_root_folder/templates/jsn_epic_XXX/images/, where XXX the 

template edition you have. All you have to do is to create your logo, save it with the same name logo.png and 

upload it to your server overwriting the original logo. 

If you have permission problems while using FTP, then we strongly recommended you to use great Joomla 

extension called JoomlaXplorer. You can download it for free from JED at: 

http://extensions.joomla.org/extensions/core-enhancements/file-management/102 

For instruction about how to change the default logo to your own please refer to JSN Epic v3 Configuration 

Manual section Logo. 

http://extensions.joomla.org/extensions/core-enhancements/file-management/102
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Top Menu 

 

 Top Menu Icons is available only in JSN Epic PRO edition. 

The top menu you see on JSN Epic demo site is a very innovative Icon menu system called Top Menu Icons. By 

combination XHTML, CSS and Javascript, Top Menu Icons allows you to assign up to 20 predefined icons to 

menu items and arrange them in horizontal line. This is perfect for top position in any kind of websites. 

Please make following steps to setup Top Menu Icons: 

1. In module manager click on the menu module you want to use as top menu module. By default, Joomla! 1.5 

comes with various menu modules and there is Top Menu module among them. That might be the perfect 

choice. 

2. In module’s configuration page setup following parameters: 

 Title: Top Menu (or any other you like) 

 Show title: No 

 Enabled: Yes 

 Position: inset 

 Menus: All 

 Menu Name: topmenu (you might want to use another menu source here) 

 Menu Style: List 

 Start Level: 0 

 End Level: 1 

 Always show sub-menu Items: No 
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 Menu Tag ID:base-topmenu 

 Menu Class Suffix: empty 

 Module Class Suffix: empty 

Attention: There is common misconception about Menu Class Suffix and Module Class Suffix. They 

are absolutely different parameters, so please pay attention on their settings. 

3. Now you need to go to template configuration page and setup icons to be shown in the menu. Find template 

parameter Top Menu Icons and specifying icon names separated by comma as “home,cart,download”. 

For more information about all available menu styles please refer to JSN Epic v3 Configuration Manual section 

Menu. 
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Main Menu 

 

By just combination XHTML, CSS and little JavaScript (only for IE) Main Menu allows you to have clean 

accessible XHTML code structure and simple yet effective drop-down submenu panels. 

Please make following steps to setup Main Menu: 

1. In module manager click on the menu module you want to use as main menu module. By default, Joomla! 

1.5 comes with various menu modules and there is Main Menu module among them. That might be the 

perfect choice. 

2. In module’s configuration page setup following parameters: 

 Title: Main Menu (or any other you like) 

 Show title: No 

 Enabled: Yes 

 Position: mainmenu 

 Menus: All 

 Menu Name: mainmenu (you might want to use another menu source here) 

 Menu Style: List 

 Start Level: 0 

 End Level: 0 
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 Always show sub-menu Items: Yes 

 Menu Tag ID:base-mainmenu 

 Menu Class Suffix: empty 

 Module Class Suffix: empty 

Special visual effects 

 Special visual effects are available only in JSN Epic PRO edition. 

On demo server JSN Epic is presented with smooth drop down animation for submenu panels. To enable the effect 

go to template configuration page and set template parameter Main Menu Effect to Yes. 

Another visual effect demonstrated in demo server is transparency for submenu panels. To enable submenu 

transparency you need to set template parameter Main Menu Transparency to Yes. 

For more information about all available menu styles please refer to JSN Epic v3 Configuration Manual section 

Menu. 

Main Menu Icons 

 

 Main Menu Icons feature is available only in JSN Epic PRO edition. 

In v3, JSN Epic lets you configure which icon will be shown in Main Menu via template parameter Main Menu 

Icons. You can assign up to 20 predefined icons to menu items by choosing from drop-down panel in template 

parameter. 

For more information about all available menu styles please refer to JSN Epic v3 Configuration Manual section 

Menu. 
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Site Tools  

 

 Site Tools is available only in JSN Epic PRO edition. 

As with v3 JSN Epic provides 3 brand new features to enhance website user experience: Text Size Selector, 

Width Selector and Color Selector. All selectors are elegantly arranged in a menu called Site Tools and can be 

displayed like a drop-down box or horizontal in-line mode via template parameters Site tools Presentation. All 

settings from Site tools will be stored as visitor’s browser cookies for further usage. 

By default all selectors are turned on so you don’t have to make any additional actions. You can disable one or 

more selectors by setting 3 template parameters Enable Text Size Selector , Enable Width Selector and Enable 

Color Selector. 

For more information about all available menu styles please refer to JSN Epic v3 Configuration Manual section 

Usability & Accessibility. 
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Primary Promotion area configuration 

Header image slideshow 

 

The header image slideshow you see on JSN Epic demo website is another cool Joomla! extension from 

JoomlaShine.com called JSN ImageShow. You can download JSN ImageShow Free edition at no cost from 

Customer Area or JSN ImageShow download page. For more information about how to work with JSN 

ImageShow please go to JoomlaShine Docs portal. 

Stage 1: Prepare images to be included in slideshow 

In this stage you are going to get your images ready for the slideshow. JSN ImageShow is able to automatically 

resize your images to match the slideshow size, but for the best result we’d recommend you to pay attention to 

preparing your images. The main thing here is to crop your images so they have size similar to slideshow area size. 

That means the width/height ratio of sizes should be the same or similar. For example, if you have slideshow area 

with size 450px * 300px (the ratio is 1.5) then your images would better be in the range from 375px * 235px (the 

ratio is 1.6) to 525px * 375px (the ratio is 1.4). 

Another thing worth mention here is JSN ImageShow works best with JPEG format, so if you are going to show 

photos, please use JPEG format. 

Stage 2: Upload images to the source 

Now, when your images are ready, it’s time to upload them to the source. JSN ImageShow is able to get images 

from following sources: 

http://www.joomlashine.com/docs/joomla-extensions/jsn-imageshow.html
http://www.joomlashine.com/customer-area.html
http://www.joomlashine.com/joomla-extensions/buy-jsn-imageshow.html
http://www.joomlashine.com/docs/joomla-extensions/jsn-imageshow.html
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 Local image folder – This is simple folder inside your Joomla root folder. Best if image folder is located 

under folder “images”. 

 Joomla Galleries – Current JSN ImageShow support 2 very well-known Joomla photo gallery extensions 

called Phoca Gallery and JoomGallery. If you already using some of them, then you can configure showlist 

to take images from there. 

 Phoca Gallery – Besides from local sources on your server. JSN ImageShow is able to take images from 

external sources Flickr and Picasa.  

Now, to make simply the process, let’s assume we will create folder myphotos under folder images/ and upload all 

images there by FTP client. 

Stage 3: Create showlist in JSN ImageShow administration panel 

Now when images are ready on the server, it’s time to create a showlist, which contains information about what 

images to shown. Please make following steps: 

1. Go to JSN ImageShow Control Panel by menu Components -> JSN ImageShow -> Showlists 

2. Click on button New on toolbar, input title Sample Promo Images and click Apply 

3. Click on button Manage Images, then Select new Image Source  

4. Next, select Image Folder option and click Choose selected source  

5. Next, in appeared modal window select option Add all images from selected folders and select folder 

myphotos in the list. 

6. Click Ok, now you will see all images in the list. 

Stage 4: Create showcase in JSN ImageShow administration panel 

Now when the showlist is ready, we need to create a showcase, which contain information about how to show 

images selected in showlist. Please make following steps: 

1. Go to JSN ImageShow Control Panel by menu Components -> JSN ImageShow -> Showcases 

2. Click on button New on toolbar, input title Sample Slideshow and click Apply 

3. In section Showcase Parameters go to tab SlideShow and set parameter Auto Play to Yes. You can return 

back to showcase setting page later for more configuration, but for now, the settings are good enough. 

http://www.phoca.cz/phocagallery
http://www.joomgallery.net/
http://www.flickr.com/
http://picasa.google.com/
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4. Click button Save on toolbar. 

Stage 5: Configure JSN ImageShow module in appropriate position 

Now when you have configured showlist and showcase, it’s time to setup JSN ImageShow module to present it. 

Please make following steps: 

1. Go to module manager by menu Extensions -> Module Manager 

2. Click on JSN ImageShow item in the list and setup parameters as following: 

 Show title: No 

 Position: promo 

 Enabled: Yes 

 Menus: All (or at least Home) 

 Showlist: Sample Promo Images 

 Showcase: Sample Slideshow 

 Overall Width (px, %): 100% 

 Overall Height (px): 280 

Attention: All stock photos used on JSN Epic demo website are only for demo purposes and NOT included in the 

template package. 
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Featured user modules 

 

 Position user9 used in example above and position user8 are available only in JSN Epic PRO edition. 

The text module near image slideshow is just simple User module created to contain some sample content. 

To create that module please make following steps: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click button New on the top toolbar. 

3. Click line Custom HTML. 

4. In new module’s configuration page you need to setup following parameters 

 Title: User Module (or anything you like) 

 Show title: Yes 

 Position: user8 (for the left-side module) or user9 (for the right-side module) 

 Enabled: Yes 
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 Custom Output: 

Your content’s text 

 Menus: All (or at least Home) 

5. Click button Save 

Left column configuration 

Tree Menu 

 

The side menu you see on left column is vertical tree-like menu presentation called Tree Menu. By default all 

submenu items are collapsed until you select the parent menu item. Submenu items of each level have their own 

bullets to make it easier to distinguish. Please make following steps: 

1. In module manager click on the menu module you want to use as main menu module. By default, Joomla! 

comes with various menu modules and there is Resources module among them. That might be the perfect 

choice. 

2. In module’s configuration page setup following parameters: 

 Title: Tree Menu (or any other you like) 
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 Show title: Yes 

 Enabled: Yes 

 Position: left 

 Menus: All (or at least Home) 

 Menu Name: othermenu (you might want to use another menu source here) 

 Menu Style: List 

 Start Level: 0 

 End Level: 0 

 Always show sub-menu Items: No 

 Menu Tag ID: empty 

 Menu Class Suffix:-treemenu 

 Module Class Suffix:-box box-grey icon-star 

3. Click button Save 

 All icons to be used in module header are available only in JSN Epic PRO edition. 

For more information about all available menu styles and module styles please refer to JSN Epic v3 

Configuration Manual section Menu. 
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Login Form 

 

The Login Form you see on left column module is standard Login Form module shown with Green Box module 

styles and User icon in module’s title. Let’s see how to set it up: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click on Login Form in module list. 

3. In module’s configuration page you need to setup following parameters 

 Title: Login Form (or anything you like) 

 Show title: Yes 

 Position: left 

 Enabled: Yes 

 Menus: All (or at least Home) 

 Module Class Suffix:-box box-green icon-user 

4. Click button Save 
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 All icons to be used in module header are available only in JSN Epic PRO edition. 

For more information about all available module styles and icons please refer to JSN Epic v3 Configuration 

Manual section Module Styles. 
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Syndicate 

 

The Syndicate module you see on left column is standard Syndicate module shown with plain background and RSS 

icon in module’s title. Let’s see how to set it up: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click on Syndicate in module list. 

3. In module’s configuration page you need to setup following parameters 

 Title: Syndication (or anything you like) 

 Show title: Yes 

 Position: left 

 Enabled: Yes 

 Menu Assignment: All (or at least Home) 

 Module Class Suffix:-plain icon-rss 

4. Click button Save 

 All icons to be used in module header are available only in JSN Epic PRO edition. 

For more information about all available module styles and icons please refer to JSN Epic v3 Configuration 

Manual section Module Styles. 



Joomla! template JSN Epic v3 Quick Start Guide © http://www.joomlashine.com 

 27

Stick Left Module 

 

The module in stick left position is just simple Custom HTML module created to contain sample content. To create 

that module please make following steps: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click button New on the top toolbar. 

3. Click line Custom HTML. 

4. In new module’s configuration page you need to setup following parameters 

 Title: Stick Left Module (or anything you like) 

 Show title: No 

 Position: stickleft 

 Enabled: Yes 

 Menus: All (or at least Home) 

5. Click button Save. 
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Right column configuration 

Newsflash 

 

The Newsflash module you see on right column is standard Newsflash module shown with Yellow Box module 

styles and Article icon in module’s title. Let’s see how to set it up: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click on Newsflash in module list. 

3. In module’s configuration page you need to setup following parameters 

 Title: Newsflash (or anything you like) 

 Show title: Yes 

 Position: right 

 Enabled: Yes 

 Menus: All (or at least Home) 

 Module Class Suffix:-box box-yellow icon-comment 
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4. Click button Save 

 All icons to be used in module header are available only in JSN Epic PRO edition. 

For more information about all available module styles and icons please refer to JSN Epic v3 Configuration 

Manual section Module Styles. 
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Polls 

 

The Polls module you see on right column is standard Polls module shown with Blue Box module styles and 

Selection icon in module’s title. Let’s see how to set it up: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click on Polls in module list. 

3. In module’s configuration page you need to setup following parameters 

 Title: Polls (or anything you like) 

 Show title: Yes 

 Position: right 

 Enabled: Yes 

 Menus: All (or at least Home) 

 Module Class Suffix:-box box-blue icon-selection 

4. Click button Save 
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 All icons to be used in module header are available only in JSN Epic PRO edition. 

For more information about all available module styles and icons please refer to JSN Epic v3 Configuration 

Manual section Module Styles. 



Joomla! template JSN Epic v3 Quick Start Guide © http://www.joomlashine.com 

 32

Who’s Online 

 

The Who’s Online module you see on right column is standard Who’s Online module shown with plain 

background and Online icon in module’s title. Let’s see how to set it up: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click on Who’s Online in module list. 

3. In module’s configuration page you need to setup following parameters 

 Title: Who’s Online (or anything you like) 

 Show title: Yes 

 Position: right 

 Enabled: Yes 

 Menu Assignment: All (or at least Home) 

 Module Class Suffix:-plain icon-online 

4. Click button Save 

 All icons to be used in module header are available only in JSN Epic PRO edition. 

For more information about all available module styles and icons please refer to JSN Epic v3 Configuration 

Manual section Module Styles. 
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Stick Right Module 

 

The module in stick right position is just simple Custom HTML module created to contain sample content. To 

create that module please make following steps: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click button New on the top toolbar. 

3. Click line Custom HTML. 

4. In new module’s configuration page you need to setup following parameters 

 Title: Stick Right Module (or anything you like) 

 Show title: No 

 Position: stickright 

 Enabled: Yes 

 Menu Assignment: All (or at least Home) 

5. Click button Save 
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Main content area 

Welcome module 

 

The Welcome module is just simple User module created to contain some sample content. It’s shown in plain 

background with Icon Star icon. To create that module please make following steps: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click button New on the top toolbar. 

3. Click line Custom HTML 

4. In new module’s configuration page you need to setup following parameters 

 Title: Welcome (or anything you like) 

 Show title: Yes 

 Position: user1 

 Enabled: Yes 

 Menus: All (or at least Home) 

 Module Class Suffix:-plain icon-mail 
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5. Click button Save. 

Now, when you have got the idea how to have Welcome module, it’s time to setup your own image and text. The 

best size for your welcome image is 210px * 100px. 

Attention: The value of Custom Output parameter above should be inputted as pure HTML code. If you have 

WYSIWYG editor turned on (by defaut), then you need to push button HTML and input HTML code into the 

popup window HTML Source Editor. 

 

If the WYSIWYG editor is turned off, you can input directly to Custom Output field. 

Attention: All stock photos used on JSN Epic demo website are only for demo purposes and NOT included in the 

template package. 
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About Us module 

 

The About Us module is pretty similar to the Welcome module discussed in previous section. The major 

difference here is it’s published in another module position. To create that module please make following steps: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click button New on the top toolbar. 

3. Click line Custom HTML 

4. In new module’s configuration page you need to setup following parameters 

 Title: About Us (or anything you like) 

 Show title: Yes 

 Position: user2 

 Enabled: Yes 

 Menus: All (or at least Home) 

 Module Class Suffix:-plain icon-image 

 Custom Output: 

<img class="image-left image-border" src="http://demo.joomlashine.com/joomla-
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templates/jsn_epic/images/jsn_epic/samples/w210_1.jpg" alt="About Us" />Lorem ipsum dolor sit 

amet, consectetuer adipiscing elit. Nullam nec odio. Vivamus turpis metus, feugiat sit amet, pulvinar 

sed, tincidunt sit amet, massa. 

5. Click button Save. 

Now, when you have got the idea how to have About Us module, it’s time to setup your own image and text. The 

best size for your about us image is 210px * 100px. 

Attention: All stock photos used on JSN Epic demo website are only for demo purposes and NOT included in the 

template package. 



Joomla! template JSN Epic v3 Quick Start Guide © http://www.joomlashine.com 

 38

Latest News 

 

The Latest News module you see is standard Latest News module shown with plain background and Article icon 

in module’s title. Let’s see how to set it up: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click on Latest News in module list. 

3. In module’s configuration page you need to setup following parameters 

 Title: Latest News (or anything you like) 

 Show title: Yes 

 Position: user3 

 Enabled: Yes 

 Menus: All (or at least Home) 

 Module Class Suffix:-plain icon-calendar 

4. Click button Save. 

 Position user3 used in example above is available only in JSN Epic PRO edition. 
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Popular 

 

The Popular module is pretty similar to the Latest News module discussed in previous section. The major 

difference here is it’s published in another module position. Let’s see how to set it up: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click on Popular in module list. 

3. In module’s configuration page you need to setup following parameters 

 Title: Popular (or anything you like) 

 Show title: Yes 

 Position: user4 

 Enabled: Yes 

 Menus: All (or at least Home) 

 Module Class Suffix:-plain icon-info 

4. Click button Save 

 Position user4 used in example above is available only in JSN Epic PRO edition. 
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Bottom Banner 

 

The Bottom Banner module is standard Banner module shown without any module styles. Let’s see how to set it 

up: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click on Banners in module list. 

3. In module’s configuration page you need to setup following parameters 

 Title: Banners (or anything you like) 

 Show title: No 

 Position: banner 

 Enabled: Yes 

 Menus: All (or at least Home) 

4. Click button Save 
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Footer area configuration 

3 bottom promotion modules 

 

 Positions user5, user6, user7 used in example above are available only in JSN Epic PRO edition. 

All 3 bottom promotion modules are pretty similar to the Welcome module discussed in previous section. The 

major difference here is they are published in other various module positions and the content part is little bit 

different. To create that module please make following steps: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click button New on the top toolbar. 

3. Click line Custom HTML. 

4. In new module’s configuration page you need to setup following parameters 

 Title: User Module (or anything you like) 

 Show title: Yes 

 Position: user5 (left) or user6 (center) or user7 (right) 

 Enabled: Yes 

 Module Class Suffix:-plain 

 Content: 

<img class="image-left image-border" src="http://demo.joomlashine.com/joomla-

templates/jsn_epic/images/jsn_epic/samples/w100_1.jpg" alt="Bottom Promotion" />Lorem ipsum 
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dolor sit amet, consectetuer adipiscing elit. Nullam sem. Cras erat ipsum, euismod ut, rutrum in, 

dignissim quis, libero. Praesent fermentum. 

 Menu Assignment: All (or at least Home) 

5. Click button Save 

Now, when you have got the idea how to have bottom promotion modules, it’s time to setup your own image and 

text. The best size for your images here is 100px * 100px. Just remember you need to repeat this process 3 times 

for all 3 user modules here. 

Attention: All stock photos used on JSN Epic demo website are only for demo purposes and NOT included in the 

template package. 
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Copyright text 

 

The Copyright text module is another User module configured to contain copyright text. To create that module 

please make following steps: 

1. Go to module manager by menu Extensions -> Module Manager. 

2. Click button New on the top toolbar. 

3. Click line Custom HTML. 

4. In new module’s configuration page you need to setup following parameters 

 Title: Copyright (or anything you like) 

 Show title: No 

 Position: footer 

 Enabled: Yes 

 Custom Output: 

Copyright &copy; 2006 - 2010 JoomlaShine.com. All rights reserved unless otherwise stated. 

 Menus: All 

5. Click button Save 

Now, you just need to setup your own text. 
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Div Menu 

 

The Div Menu in the bottom position is simple yet nice menu bar with items separated by slightly visible dashes. 

Please make following steps: 

1. In module manager click on the menu module you want to use as top menu module. By default, Joomla! 1.5 

comes with various menu modules and there is Key Concepts module among them. That might be the 

perfect choice. 

2. In module’s configuration page setup following parameters: 

 Title: Div Menu (or any other you like) 

 Show title: No 

 Enabled: Yes 

 Position: bottom 

 Menus: All 

 Menu Name: keyconcepts (you might want to use another menu source here) 

 Menu Style: List 

 Start Level: 0 

 End Level: 1 

 Always show sub-menu Items: No 

 Menu Tag ID: empty 
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 Menu Class Suffix:-divmenu 

 Module Class Suffix: empty 

3. Click button Save 
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What’s next? 

Congratulations, if you had enough patience to reach this page and most likely your website is now looking pretty 

much like JSN Epic demo website. It’s cool, but JSN Epic can do much more that what you see on demo website 

homepage. Your next step is to read the next documentation came with JSN Epic package called JSN Epic v3 

Configuration Manual. In this manual you will find detailed description about all template features and you can 

quickly apply them to your website. 

Read the latest updated tutorials 

We are updating our tutorial database frequently, so don’t forget to visit JoomlaShine Docs Portal to check 

something new. 

Give a feedback 

We are continuously working on new releases of our products and would really appreciate any of your comments, 

feedbacks. Feel free to drop us a line at Feedback Page. 

http://www.joomlashine.com/docs/joomla-templates/jsn-epic.html
http://www.joomlashine.com/contact-us/product-feedback.html
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